Срочно!! Напишите программу, которая сортирует одномерный массив. Дана матрица размерами...

0 голосов
81 просмотров

Срочно!! Напишите программу, которая сортирует одномерный массив.


Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная – в ячейке должно содержаться произведение индексов, если сумма индексов нечетная – в ячейке должна содержаться сумма индексов.


Информатика (19 баллов) | 81 просмотров
0

Паскаль? Бейсик? Си?

0

Паскаль

Дан 1 ответ
0 голосов
Правильный ответ

1)

Const
   N = 13;
Var
   A:array[1..N] of integer;
   i,j:integer;
Begin
For i:= 1 to N do
    Begin
    A[i]:=random(21)-10;
    Write(A[i],' ');
    End;
WriteLn;
For j:= 1 to N do
    For i:= 1 to N-1 do
        if A[i]For i:= 1 to N do
    Write(A[i],' ');

End.



2)

Var
   A:array[1..4,1..4] of integer;
   i,j:integer;
Begin
For i:= 1 to 4 do
    Begin
    For j:= 1 to 4 do
        Begin
        if (i+j) mod 2 = 0 then A[i,j]:=i*j
        else A[i,j]:=i+j;
        Write(A[i,j],' ')
        End;
    WriteLn
    End;
End.

(34.0k баллов)
0

Спасибо вам огромное))