Напишите программу в паскале!!!!! ЗАРАНЕЕ СПАСИБО!!! Для покраски 1 м2 потолка требуется...

0 голосов
58 просмотров

Напишите программу в паскале!!!!! ЗАРАНЕЕ СПАСИБО!!!
Для покраски 1 м2 потолка требуется a г краски. Краска продается в банках по b кг. Сколько банок краски нужно купить для покраски потолка площадью c кв2?


Информатика (117 баллов) | 58 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c:integer;
Begin
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
b:=b*1000;
c:=c*a;
a:=c div b;
if c mod b <> 0 then a:=a+1;
Write('Требуемое количество банок: ',a);
End.


Пример работы программы:

a = 123
b = 4
c = 56789
Требуемое количество банок: 1747

(34.0k баллов)