Помогите пожалуйста - это Паскаль, напишите программу))

0 голосов
32 просмотров
Помогите пожалуйста - это Паскаль, напишите программу))
image

Информатика (305 баллов) | 32 просмотров
0

Разработать алгоритм и составить программу вычисления значений функций при изменении значений аргумента от начального значения до конечного с некоторым шагом соответственно вариантам

Дан 1 ответ
0 голосов

Const a = 5.8;      Pi = 3.14;var x, y, k, P, S, t: real;begin     t := sqrt(sin(x - 4));     x := -3;     while (x <= 3) do     begin          if (t < 5) then             y := sin(Pi / 2 + x) / cos (Pi / 2 - x)          else              y := Ln(a + x) / Power(a, 2);          if (y < 0) then k := k + 1;          writeln('x = ', x, '; y = ', y);<br>          x := x + 0.5;
     end;
     if (t >= 0) then
     begin
          P := P * t;
          {Сюда вставить нужно вычисление S, я не понял, что значит тот знак:)}
     end;
     Writeln('k = ', k, '; P = ', P, '; S = ', S);
end.

(16.9k баллов)
0

Где ln и sin там стоят скобочки
тот символ - это сумма

0

Сумма t и...?