Напишите программу в паскале с помощью div и mod! ЗАРАНЕЕ СПАСИБО!!! Вводится трехзначное целое число. Получить новое число, записанное этими же цифрами, но в обратном порядке.
Var a,a1,a2,a3,b:integer; begin write('a = '); readln(a); a1:=abs(a) div 100; a2:=abs(a) div 10 mod 10; a3:=abs(a) mod 10; b:=sign(a)*(a3*100+a2*10+a1); writeln(b); end. Пример: a = -456 -654
Var A:integer; Begin Write('Введите трёхзначное число: ');ReadLn(A); WriteLn(A mod 10,Abs((A div 10) mod 10),Abs(A div 100)); End. Примеры работы программы: Введите трёхзначное число: 123 321 Введите трёхзначное число: -987 -789
СПАСИБО!!!