Помогите пожалуйста написать программу в паскале. Дано ФИО, например "Петров Иван...

0 голосов
39 просмотров

Помогите пожалуйста написать программу в паскале. Дано ФИО, например "Петров Иван Андреевич", в итоге программа должна вывести - Петров И.А.


Информатика (20 баллов) | 39 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
   S,S1:string;
   i:integer;
Begin
Write('Введите ФИО: ');
ReadLn(S);
i:=1;
While S[i]<>' ' do
   i:=i+1;
For i:= 1 to i+1 do
    S1:=S1+S[i];
S1:=S1+'.';
While S[i]<>' ' do
   i:=i+1;
S1:=S1+S[i+1]+'.';
WriteLn(S1);
End.

(34.0k баллов)
0 голосов

Var s: string;
    n,m: integer;
begin
  write('ФИО: ');  readln(s);
  n:=pos(' ',s);  
  s[n]:='*';
  m:=pos(' ',s);
  s:=copy(s,1,n+1)+'.'+s[m+1]+'.';
  s[n]:=' ';
  writeln(s);
end.
 
ФИО: Петров Сидор Иванович
Петров С.И.



(9.7k баллов)