Напишите программу, вычисляющую значение функции; {1 при x<0 y= {0 при x=0 {1 при x>0...

0 голосов
137 просмотров

Напишите программу, вычисляющую значение функции;
{1 при x<0<br> y= {0 при x=0
{1 при x>0
Пример данных: -5, 0, 5
Пример вывода данных: y=-1, y=0, y=1
паскаль


Информатика (17 баллов) | 137 просмотров
Дан 1 ответ
0 голосов

Var x, y: integer;
begin
readln(x);
if (x < 0) then 
  writeln ('y = -1');
if (x = 0) then
  writeln ('y = 0')
else
  writeln ('y = 1')
end.

(1.4k баллов)