Помогите написать программу Pascal ABC, пожалуйста!) Вводится 4-х значное число. Задания:...

0 голосов
66 просмотров

Помогите написать программу Pascal ABC, пожалуйста!)
Вводится 4-х значное число.
Задания:
1) Вывести число это же число, в котором меняется местами 1 и 2 цифра, 3 и 4 цифра, например 1234=2143.
2) Если в перевернутом числе 1 двухзначное число>второго , то вывести 1 двухзначное число , если нет, то 2 двухзначное число. Например, 2143= 21<43 , следовательно выводится 43.<br> 3) Найти произведение всех цифр, перевернутого числа.
Заранее спасибо!)


Информатика (73 баллов) | 66 просмотров
0

Спасибо! Я исправил отпечатку)

Дан 1 ответ
0 голосов
Правильный ответ

Var
   a:integer;
   b,c,d:byte;
Begin
Write('Введите четырёхзначное число: ');
ReadLn(a);
b:=a div 1000;
c:=(a div 100) mod 10;
d:=(a div 10) mod 10;
a:=a mod 10;
WriteLn('1: ',c,b,a,d);
WriteLn('3: ',a*b*c*d);
c:=c*10+b;
d:=a*10+d;
if c>d then WriteLn('2: ',c)
else WriteLn('2: ',d)
End.


Примеры работы программы:

Введите четырёхзначное число: 6547
1: 5674
3: 840
2: 74
Введите четырёхзначное число: 9753
1: 7935
3: 945
2: 79
Введите четырёхзначное число: 3149
1: 1394
3: 108
2: 94

(34.0k баллов)