Напишите программу ** языке программирования Pascal. Дано натуральное число n. Если число...

0 голосов
62 просмотров

Напишите программу на языке программирования Pascal. Дано натуральное число n. Если число большое нуля, то вывести это число, увеличенное в 7 раз, а иначе вывести квадрат этого числа.


Информатика (829 баллов) | 62 просмотров
0

Ты не знаешь?

0

неа

0

Ты шо я дуб

0

И это

0

магила

0

Могила

Дан 1 ответ
0 голосов
Правильный ответ

1. Современное решение

PascalABC.NET 3.2, сборка 1427 от 24.04.2017
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  Writeln(n>0?n*7:n*n)
end.

2. Школьное решение в стиле ТурбоПаскаль 1983г.

var
  n:integer;
begin
  Write('n=');
  Read(n);
  if n>0 then n:=7*n
  else n:=n*n;
  Writeln(n)
end.

(150k баллов)
0

Спасибо большоое

0

Боже мой, как Вы все это понимаете

0

Это невероятно сложно