Помогите написать программу в Паскале. Дан массив размера N. 1. Найти количество...

0 голосов
38 просмотров

Помогите написать программу в Паскале.
Дан массив размера N.
1. Найти количество участков К, на которых его элементы монотонно возрастают.


Информатика (277 баллов) | 38 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-20,20); a.Println;
  var flag:=true;
  var k:=0;
  var ap:=a[0];
  for var i:=1 to a.Length-1 do begin
    if a[i]>ap then begin
      if flag then begin k+=1; flag:=false end
      end
    else flag:=true;
    ap:=a[i]
    end;
  Writeln('Кол-во участков возрастания: ',k)
end.

Пример
n= 15
-17 -2 -11 14 6 -3 -16 13 -13 -12 -16 2 15 -1 -20
Кол-во участков возрастания: 5
(150k баллов)