Напишите программу формирования и вывода массива размером 6х3, каждые три...

0 голосов
81 просмотров

Напишите программу формирования и вывода массива размером 6х3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й равен квадрату суммы индексов следующего элемента.
2-й равен удвоенной сумме текущих индексов
3-й равен разности двух предыдущих элементов.
Паскаль


Информатика (26 баллов) | 81 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Const
   N = 6;
   M = 3;
Var
   A:array[1..N,1..M] of integer;
   i:integer;
Begin
For i:= 1 to N do
    Begin
    A[i,1]:=sqr(i+2);
    A[i,2]:=2*i+4;
    A[i,3]:=A[i,2]-A[i,1];
    WriteLn(A[i,1]:3,' ',A[i,2]:3,' ',A[i,3]:3);
    End;
End.


Результат работы программы:

  9   6  -3
 16   8  -8
 25  10 -15
 36  12 -24
 49  14 -35
 64  16 -48

(34.0k баллов)
0

i + 1 + 1 +1 = i +3, а у меня i+4.....

0

Уже сходится

0

Решил, что следующий элемент, это A[i+1,j+1], и посчитал, что для j=1, i+1+j+1 = i+4...

0 голосов
// PascalABC.NET 3.2, сборка 1425 от 22.04.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=new integer[6,3];
  for var i:=0 to 5 do begin
    a[i,0]:=sqr(i+3);
    a[i,1]:=2*(i+3);
    a[i,2]:=a[i,0]-a[i,1];
    end;
  a.Println(3)
end.

Результат
  9  6  3
 16  8  8
 25 10 15
 36 12 24
 49 14 35
 64 16 48

(150k баллов)