Написать программу в паскале.

0 голосов
37 просмотров

Написать программу в паскале.


image

Информатика (1.0k баллов) | 37 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
   A,B,d:longint;
   K:real;
Begin
WriteLn('Введите границы диапазона: ');ReadLn(A,B);
For B:= A to B do
    if (B>1) then
       if (B=2)or(B=3) then Write(B,' ')
       else if (B mod 2<>0) then
            Begin
            d:=3;
            K:=Sqrt(B);
            While (d<=K)and(B mod d<>0) do
               d:=d+2;
            if B mod d<>0 then Write(B,' ')
            End;
End.

(34.0k баллов)