Написать программу с помощью операторы if. Оператор for применять не требуется. Ладья...

0 голосов
88 просмотров

Написать программу с помощью операторы if. Оператор for применять не требуется.
Ладья бьет либо строго вертикально на любой клетке, либо строго горизонтально. В этом случае меняется у фигуры либо только координата X(номер строки), либо только координата Y(номер столбца).
Требуется определить, бьет ли ладья, стоящая на клетке с указанными координатами (номер строки и номер столбца), фигуру, стоящую на другой указанной клетке.
Входные данные
Вводятся четыре числа: координаты ладьи (два числа) и координаты другой фигуры (два числа), каждое число вводится в отдельной строке. Координаты - целые числа в интервале от 1 до 8.
Выходные данные
Требуется вывести слово YES, если ладья сможет побить фигуру за 1 ход и NO - в противном случае.

Примеры
Входные данные
1
1
2
2
Выходные данные
NO

Входные данные
1
1
2
1
Выходные данные
YES


image

Информатика (1.1k баллов) | 88 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
   x1,y1,x2,y2:byte;
Begin
Read(x1,y1,x2,y2);
if (x1-x2 = 0)xor(y1-y2 = 0) then Write('YES')
else Write('NO')
End.

(34.0k баллов)