Помогите написать программу в Free Pascal'e,пожалуйста! Условие: Пусть k - целое от 1 до...

0 голосов
55 просмотров

Помогите написать программу в Free Pascal'e,пожалуйста!
Условие: Пусть k - целое от 1 до 365. Присвоить целой переменной n значение 1, 2, ..., 6 или 7 в зависимости от того, на какой день недели (понедельник, вторник, ..., субботу или воскресенье) приходится k-й день не високосного года, в котором 1 января - понедельник.


Информатика (63 баллов) | 55 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var k,n:integer;
begin
write('k = ');
readln(k);
n:=(k-1) mod 7+1;
writeln('n = ',n);
end.

Пример:
k = 21
n = 7

(194k баллов)