Составьте программу для решения следующей задачи: пират Флинт положил некоторую сумму S в...

0 голосов
91 просмотров

Составьте программу для решения следующей задачи: пират Флинт положил некоторую сумму S в банк под 3% годовых. Через сколько лет сумма превысит 1,5S? начальное значение S вводится с клавиатуры


Информатика (22 баллов) | 91 просмотров
Дан 1 ответ
0 голосов

Программак на языке C#:
using System;using System.Collections.Generic;using System.Linq;using System.Text;using System.Threading.Tasks;
namespace examplezn{    class Program    {        static void Main(string[] args)        {            double s = Int32.Parse(Console.ReadLine());        double need = 1.5*s;        int i = 0;        while (s<=need) {        s = (s + s*0.03);        i++;<br>        }
Console.WriteLine("Через " + i + " лет");    Console.ReadKey();        }    }}