Помогите написать программу в Паскаль, которая будет вычислять площадь круга и длину...

0 голосов
57 просмотров

Помогите написать программу в Паскаль, которая будет вычислять площадь круга и длину окружности произвольного радиуса.


Информатика (75 баллов) | 57 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
   r:real;
Begin
Write('Введите радиус круга: ');ReadLn(r);
WriteLn('Площадь круга: ',Pi*r*r);
WriteLn('Длина окружности: ',2*Pi*r)
End.

(34.0k баллов)
0 голосов

Program p;
var s,l,r:integer;
begin
writeln('Радиус круга >>');
read(r);
s:=3.14*r*r;
l:=2*r*3.14;
writeln('Площадь >>', s);
writeln('Длина >>', l);
end.

(31 баллов)
0

Не скомпилируется

0

почему?

0

"3,14" должна быть точка, а не запятая. Да к тому же, в Паскале есть константа Pi

0

тоочна

0

спасибо