Напишите программу удаляющая из текста все буквы совпадающие с его последней буквой

0 голосов
61 просмотров

Напишите программу удаляющая из текста все буквы совпадающие с его последней буквой


Информатика (121 баллов) | 61 просмотров
0

последнюю букву тоже нужно удалять?

0

незнаю, если честно

0

АВС

0

да

0

На паскале?

0

а то мне , кровь из носа, надо

0

решишь?

0

ну давай ипусть не удаляет

Дано ответов: 2
0 голосов

Uses crt;
var s:string;
n,i:integer;
begin
readln(s);
n:=length(s);
for i:=1 to n do
if s[i]=s[n] then delete(s,i,1);
writeln(s);
end.

Эта программа рассчитана на то, что удаляется и последний символ тоже

(1.4k баллов)
0

А у меня выход за границы массива, т.к. n не меняется, ну да ладно.

0

у меня все подошло)))

0

аа получилось))))

0

ага , сейчас проверю

0 голосов

Var s:string; i:integer;
begin
read(s);
i:=1;
while iif s[i]=s[length(s)] then s:=copy(s,1,i-1)+copy(s,i+1,length(s)-i)
else i+=1;
write(s)
end.

(8.5k баллов)
0

обычный

0

А, у вас обычный или .net? Если обычный, то лучше другой вариант.

0

спасибо))))

0

оо, у тебя не удаляет, я незнаю какой точно переписывать

0

тоже спасибо)))

0

Ясно