Помогите написать программу в Паскаль. Сформировать массив, подметить кол-во...

0 голосов
37 просмотров

Помогите написать программу в Паскаль.
Сформировать массив, подметить кол-во отрицательных элементов и заменить их на 2


Информатика (15 баллов) | 37 просмотров
0

подметить

0

Ну то есть, найти и вывести количество отрицательных элементов?

0

да

Дан 1 ответ
0 голосов
Правильный ответ

Const
   N = 13;
Var
   A:array[1..N] of integer;
   i,k:integer;
Begin
Randomize;
k:=0;
Write('Исходный массив:');
For i:= 1 to N do
    Begin
    A[i]:=random(21)-10;
    Write(' ',A[i]);
    if A[i] < 0 then
       Begin
       k:=k+1;
       A[i]:=2
       End;
    End;
WriteLn;
WriteLn('Количество отрицательных элементов: ',k);
Write('Новый массив:');
For i:= 1 to N do
    Write(' ',A[i])
End.



Пример работы программы:

Исходный массив: -1 -9 7 -2 -5 -3 -1 6 3 -6 9 8 -10
Количество отрицательных элементов: 8
Новый массив: 2 2 7 2 2 2 2 6 3 2 9 8 2

(34.0k баллов)