. Составить программу, решающую следующую задачу: Вы продавец, и у Вас имеются гири весом...

0 голосов
95 просмотров

. Составить программу, решающую следующую задачу: Вы продавец, и у Вас имеются гири весом 1, 2, 5 кг. Наберите минимальное количество гирь для взвешивания N кг.Язык программирования-паскаль


Информатика (27 баллов) | 95 просмотров
0

На каком языке?

0

Паскаль

0

паскаль я не очень-то шарю

Дан 1 ответ
0 голосов

Var N, a, b: integer;
begin
     readln(N);
     a := N div 5;
     N := N mod 5;
     b := N div 2;
     WriteLn(a, 'x5, ', b, 'x2, ', N mod 2, 'x1');
end.

Вот так, делением можно)

(16.9k баллов)