Напишите программу в Pascal : какое из чисел больше корень 17 или сумма корня 10 и корня...

0 голосов
40 просмотров

Напишите программу в Pascal : какое из чисел больше корень 17 или сумма корня 10 и корня 7. Эти числа нужно выразить через b и c


Информатика (117 баллов) | 40 просмотров
0

корень 17 через b и сумма корня 10 и корня 7 через c наверное

Дан 1 ответ
0 голосов
Правильный ответ

Var b,c:real;
begin
b:=sqrt(17);
writeln('b = sqrt(17) = ',b:4:2);
c:=sqrt(10)+sqrt(7);
writeln('c = sqrt(10)+sqrt(7) = ',c:4:2);
if b>c then writeln('sqrt(17) > sqrt(10)+sqrt(7)')
else writeln('sqrt(10)+sqrt(7) >= sqrt(17)');
end.

Пример:
b = sqrt(17) = 4.12
c = sqrt(10)+sqrt(7) = 5.81
sqrt(10)+sqrt(7) >= sqrt(17)

(194k баллов)
0

спасибо