Напишите программу, которая выводит ** экран все цифры числа, начиная с первой. Входные...

0 голосов
545 просмотров

Напишите программу, которая выводит на экран все цифры числа, начиная с первой.

Входные данные
Входная строка содержит натуральное число N .

Выходные данные
Программа должна вывести все цифры введённого числа в одной строке, начиная с первой. Цифры отделяются пробелами.

Примеры
входные данные
123
выходные данные
1 2 3
На паскале.


Информатика (27 баллов) | 545 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
А еще так можно:

PascalABC.NET 3.2, сборка 1399 от 08.03.2017

Внимание! Если программа не работает, обновите версию!

begin
 ReadlnString.Println(' ')
end.

Пример
123
1 2 3
(150k баллов)
0 голосов

Можно так:

Var S:string;
i:integer;
Begin
Read(S);
For i:= 1 to Length(S) do
    Write(S[i],' ')
End.


И так:

Var A,B:integer;
Begin
Read(A);
B:=0;
While A<>0 do
   Begin
   B:=B*10+(A mod 10);
   A:= A div 10
   End;
While B<>0 do
   Begin
   Write(B mod 10,' ');
   B:=B div 10
   End;
End.

(34.0k баллов)