Сортировка. Метод выбора. Напишите программу, которая сортирует массив и находит...

0 голосов
114 просмотров

Сортировка. Метод выбора.
Напишите программу, которая сортирует массив и находит количество различных чисел в нем.
Пример:
Массив: 5 3 4 2 1 6 3 2 4
После сортировки: 1 2 2 3 3 4 4 5 6
Различных чисел: 6
Срочно нужно .Помогите пожалуйста ,люди ,добрые


Информатика (439 баллов) | 114 просмотров
Дан 1 ответ
0 голосов

Begin
  var c, min, imin: integer;
  c := 0;
  var ar := readarrinteger('Массив:',readinteger());
  for var i := 1 to ar.Length do
  begin
    min := ar[c];
    imin := c;
    for var j := c to ar.Length - 1 do
    begin
      if(ar[j] < min) then
      begin
        min := ar[j];
        imin := j;
      end;
    end;
    swap(ar[c], ar[imin]);
    c := c + 1;
  end;
  write('После сортировки: ');
  ar.Println;
  write('Различных чисел: ',ar.Distinct.Count);
end.

(3.7k баллов)