Напишите программу (паскаль) для вычисления разности S=1 - 1*2 - 1*2*5 - 1*2*5*8 -...

0 голосов
31 просмотров

Напишите программу (паскаль) для вычисления разности
S=1 - 1*2 - 1*2*5 - 1*2*5*8 - 1*2*5*8*11


Информатика (15 баллов) | 31 просмотров
0

Количество членов последовательности вводится клавиатуры? Или это весь ряд?

Дан 1 ответ
0 голосов
Правильный ответ

Первый вариант:

Var
   A,N:longint;
   S,P:real;
Begin
Write('Введите количество членов последовательности(не менее одного): ');
ReadLn(N);
S:=1;
P:=1;
For N:= 0 to N-1 do
    Begin
    P:=P*(2+N*3);
    S:=S-P
    End;
WriteLn('S = ',S);
End.



Второй вариант:

Var
   A,N:longint;
   S,P:real;
Begin
S:=1;
P:=1;
For N:= 0 to 3 do
    Begin
    P:=P*(2+N*3);
    S:=S-P
    End;
WriteLn('S = ',S);
End.

(34.0k баллов)