СРОЧНООО! ПОМОГИТЕ ПО ИНФЕ! Написать программу через PascalABC :з Задача 2. Составить...

0 голосов
52 просмотров

СРОЧНООО! ПОМОГИТЕ ПО ИНФЕ!
Написать программу через PascalABC :з
Задача 2. Составить программу, решающую следующую задачу: Дано трехзначное число. Вывести число, полученное при перестановке крайних цифр исходного числа.

Задача 3. Составить программу, решающую следующую задачу: Вы продавец, и у Вас имеются гири весом 1, 2, 5 кг. Наберите минимальное количество гирь для взвешивания N кг.


Информатика (19 баллов) | 52 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

2.
var a,b:integer;
begin
write('a = ');
readln(a);
b:=(a mod 10)*100 + (a div 10 mod 10)*10 + a div 100;
writeln('b = ',b);
end.

Пример:
a = 194
b = 491

3.
var n,k5,k2,k1:integer;
begin
write('n = ');
readln(n);
k5:=n div 5;
k2:=(n-k5*5) div 2;
k1:=n-k5*5-k2*2;
writeln('5 кг - ',k5,', 2 кг - ',k2,', 1 кг - ',k1);
end.

Пример:
n = 18
5 кг - 3, 2 кг - 1, 1 кг - 1

(194k баллов)