Помогите написать программу в паскале В массиве А (15) целых чисел поменять местами 5 и...

0 голосов
56 просмотров

Помогите написать программу в паскале
В массиве А (15) целых чисел поменять местами 5 и 13 элементы. Вывести начальный и изменены массивы в строку через два пробела.


Информатика (328 баллов) | 56 просмотров
0

да нет, надо, то с инетом проблемы, не могу нормально зайти..(

0

да, пускай так

0

Через два пробела выводить элементы каждого массива, а сами массивы с новой строки

Дано ответов: 2
0 голосов
Правильный ответ
program fff;
const
  n = 15;
var
  arr: array[1..n] of integer;
  t : integer;
begin
  for t := 1 to n do begin
    arr[t] := random(101);
    write(arr[t], '  ');
  end;
  writeln();
  t := arr[5];
  arr[5] := arr[13];
  arr[13] := t;
  for t := 1 to n do begin
    write(arr[t], '  ');
  end;
end.
(254 баллов)
0 голосов
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(15,-50,50); a.Println('  ');
  Swap(a[4],a[12]); // индексы от нуля
  a.Println('  ')
end.

Пример
40  28  18  1  35  -50  13  17  40  7  -48  46  -12  -9  50
40  28  18  1  -12  -50  13  17  40  7  -48  46  35  -9  50

(150k баллов)