Напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой....

0 голосов
818 просмотров

Напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой. Используйте процедуру.

Входные данные
Входная строка содержит неотрицательное число N .

Выходные данные
Программа должна вывести в столбик все цифры введённого числа, начиная с первой.

Примеры
входные данные
1234
выходные данные
1
2
3
4
На паскале.


Информатика (25 баллов) | 818 просмотров
0

Процедуру рекурсивную?

0

Это как?

0

То есть рекурсию не проходили.. Это когда процедура или функция внутри себя, себя же вызывает

0

Нет, не проходили ещё к сожалению.

Дан 1 ответ
0 голосов
Правильный ответ

Без рекурсии:

Procedure ABC(N:integer);
Var
C:integer;
Begin
C:=0;
While N>0 do
   Begin
   C:=C*10+N mod 10;
   N:=N div 10
   End;
While C>0 do
   Begin
   WriteLn(C mod 10);
   C:=C div 10
   End
End;

Var
N:integer;
Begin
Write('N = ');ReadLn(N);
ABC(N);
End.


С рекурсией:

Procedure ABC(N:integer);
Begin
if N>0 then
   Begin
   ABC(N div 10);
   WriteLn(N mod 10);
   End
End;
Var N:integer;
Begin
Write('N = ');ReadLn(N);
ABC(N);
End.

(34.0k баллов)
0

Спасибо большое.