Напишите программу по 2,3и4 задание.HEIP!!!

0 голосов
41 просмотров

Напишите программу по 2,3и4 задание.HEIP!!!


image

Информатика (126 баллов) | 41 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    a, b: integer;
    x, y, z, t: integer;

begin
    {2}
    Readln(a);
    Writeln(Sign(a) * abs(a + 3));
    
    {3}
    Readln(a, b);
    if a > b then a := b;
    Writeln(a);
    
    {4}
    Readln(x, y, z);
    if (x > y) and (y > z) then t := 5
    else t := -1;
    x := x * t;
    y := y * t;
    z := z * t;
    Writeln(x, ' ', y, ' ', z)
end.

(55.0k баллов)