Помогите написать программу ** паскале) сортировка Пузырьком

0 голосов
48 просмотров

Помогите написать программу на паскале)
сортировка Пузырьком


Информатика (50 баллов) | 48 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const
   K = 13;
Var
   A:array[1..K] of integer;
   i,j:integer;
Begin
{Заполнение массива}
Write('Исходный массив: ');
For i:= 1 to K do
    Begin
    A[i]:=random(21)-10;
    Write(A[i],' ')    
    End;
WriteLn;
{Сортировка пузырьком}
For i:= 1 to K do
    For j:= 1 to K-1 do
        if A[j]>A[j+1] then Swap(A[j],A[j+1]);
{Вывод массива}
Write('Отсортированный массив: ');
For i:= 1 to K do
    Write(A[i],' ')
End.

(34.0k баллов)