Написать программу паскаль: y=x^2+b^2 заранее спасибо))

0 голосов
39 просмотров

Написать программу паскаль: y=x^2+b^2
заранее спасибо))


Информатика | 39 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
var x,b,y:integer;
begin
write('x = ');
readln(x);
write('b = ');
readln(b);
y:=x*x+b*b;
writeln('y = ',y);
end.

Пример:
x = 5
b = 8
y = 89
(194k баллов)
0 голосов

Var a,b,c,d,x:real;begin     writeln('введите A,B,C');     readln( a,b,c );     d:=sqr(b)-4*a*c;     if d<0 then begin</span>        writeln('действительных корней нет');     end else if d=0 then begin        x:=(-b)/2*a;        writeln('корень уравнения: ',x);     end else begin        x:=(-b+sqrt(d))/2*a;        writeln('1-й корень уравнения: ',x);        x:=(-b-sqrt(d))/2*a;        writeln('2-й корень уравнения: ',x);     endend.

(34 баллов)