Нужно написать программу: дан массив. Нужно отдельно вычислить отдельно сумму чисел,...

0 голосов
29 просмотров

Нужно написать программу: дан массив. Нужно отдельно вычислить отдельно сумму чисел, меньших и больших заданного K. Помогите пожалуйста!


Информатика (57 баллов) | 29 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1399 от 08.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var k:=ReadInteger('k=');
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  Writeln('Сумма элементов, меньших ',k,': ',
    a.Where(x->x  Writeln('Сумма элементов, больших ',k,': ',
    a.Where(x->x>k).Sum)
end.

Пример
k= 45
n= 15
53 45 26 -9 -34 -93 87 52 -72 16 15 -58 73 24 -22
Сумма элементов, меньших 45: -207
Сумма элементов, больших 45: 265
(150k баллов)
0

ну а если использовать только текст