Помогите составить программу, которая по сумме цифр определит делится ли число ** 3.....

0 голосов
34 просмотров

Помогите составить программу, которая по сумме цифр определит делится ли число на 3.....


Информатика (77 баллов) | 34 просмотров
0

Для того чтобы число делилось на 3, необходимо и достаточно, чтобысумма его цифр делилась на 3.

Дан 1 ответ
0 голосов
Правильный ответ

Function Div3(n:longint):boolean;
var s:byte;
begin
s:=0;
while n>0 do 
begin 
s:=s+n mod 10; 
n:=n div 10; 
end;
if s mod 3=0 then Div3:=true
else Div3:=false;
end;

var a:longint;
begin
write('Введите a: ');
readln(a);
if Div3(a) then write('Число делится на 3')
else write('Число не делится на 3');
end.

(314k баллов)
0

А это на паскале

0

да

0

Это не по сумме цифр

0

а это строчка что по твоему делает

0

s:=s+n mod 10;

0

считает сумму

0

А, тогда да