Помогите,пожалуйста, написать программу ** Паскаль Напиши программу ,которая вводит...

0 голосов
37 просмотров

Помогите,пожалуйста, написать программу на Паскаль
Напиши программу ,которая вводит десять чисел в одномерный массив ,а затем складывает по модулю отдельно все положительные элементы этого массива ,отдельно отрицательные элементы и находит разницу между ними и выдает полученные на экран через файл


Информатика (22 баллов) | 37 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var arr: array [1..10] of integer;
var i,sum,sum1:integer;
begin
for i:=1 to 10 do begin
writeln('Введите ',i,' элемент');
readln(arr[i]);
end;
sum:=0;
sum1:=0;
for i:=1 to 10 do begin
if (arr[i]>0) then begin
sum:= sum + arr[i];
end
else
if (arr[i]<0) then begin <br>sum1:= sum1 + arr[i];
end;
end;
writeln('Сумма положительных равна ',sum);
writeln('Сумма отрицательных равна ',sum1);
writeln('Разница равна ',sum-sum1);
end.