Написать программу для решения уравнения AX2+ BX+C=0. (Дописать до конца) 2)Написать...

0 голосов
37 просмотров

Написать программу для решения уравнения AX2+ BX+C=0.
(Дописать до конца)
2)Написать программу для решения неравенства Bx+C<0.<br> 3)Написать программу для решения уравнения


+ = 0


Информатика (39 баллов) | 37 просмотров
0

что в 3?

Дан 1 ответ
0 голосов

1.
program z1;
var a,b,c,x1, x2:real;
begin
writeln('введите коэффициенты А (отличное от нуля), В и С ');
readln(a,b,c);
if sqrt(b*b-4*a*c)>0 then
begin
x1:=(-b+sqrt(b*b-4*a*c))/2/a;
x2:=(-b-sqrt(b*b-4*a*c))/2/a;
writeln('x1=',x1,', x2=',x2);
end
else if sqrt(b*b-4*a*c)=0 then
begin
x1:=(-b+sqrt(b*b-4*a*c))/2/a;
writeln('x=',x1)
end
else writeln('уравнение не имеет корней');
end.

2.
program z1;
var b,c,x:real;
begin
writeln('введите коэффициенты B (отличное от нуля) и С ');
readln(b,c);
x:=-c/b;
writeln('x<',x);<br>end.

(1.1k баллов)