Помогите написать программу в паскаль АBC задание: Напишите программу которая в...

0 голосов
69 просмотров

Помогите написать программу в паскаль АBC задание:
Напишите программу которая в последовательности натуральных чисел определяет чётное минимальное число. При этом кол-во введённых чисел неизвестно. Но не превышает 1000. Введённые числа не превышают 30000.В последовательности всегда имеется чётное число. Программа должна вывести это одно минимальное чётное число.


Информатика (67 баллов) | 69 просмотров
0

Напишите условие полностью, пожалуйста

0

Входные данные: кол-во 4 числа 3 20 6 8 выходные данные 6

0

То есть, количество вводимых чисел тоже вводится

0

да

0

Большое спасибо

Дан 1 ответ
0 голосов
Правильный ответ

Var N,A,Min:integer;
Begin
Min:=30001;
Read(N);
For N:= 1 to N do
    Begin
    Read(A);
    if (A mod 2 = 0)and(A < Min) then Min:=A;
    End;
WriteLn(Min)
End.

(34.0k баллов)