Двумерные массивы. Помогите написать программу: заполнить массив 3х10там вот так...

0 голосов
54 просмотров

Двумерные массивы. Помогите написать программу:

заполнить массив 3х10
там вот так получается:
1 2 3 4 ...10
5 10 15 20 25...
25 50 75 100...

По какой-то формуле.
Заранее благодарю))


Информатика (191 баллов) | 54 просмотров
Дан 1 ответ
0 голосов

Var a: array [1..3, 1..10] of integer;
    i, m, j: integer;
begin
     for i := 1 to 3 do
         for j := 1 to 10 do
         begin
             if (i = 1) then a[i, j] := j;
             if (i = 2) then a[i, j] := 5 * j;
             if (i = 3) then a[i, j] := 25 * j;
             writeln('[', i, ', ', j, '] => ', a[i, j]);
         end;
end.

Удачи)

(16.9k баллов)