Напишите программу. и блок-схему. Вводится массив из 15 элементов,нужно определить...

0 голосов
70 просмотров

Напишите программу. и блок-схему.
Вводится массив из 15 элементов,нужно определить сколько эл. массива будут между его макс и миним. элементом.


Информатика (43 баллов) | 70 просмотров
0

Прогу на Паскале?

0

да

Дан 1 ответ
0 голосов
Правильный ответ

Uses crt;
const  n = 15;
var  i, imin, imax, m, min, max, j: integer;
  a: array[1..n]of integer;
begin 
Writeln('Введите числа в массив'); 
for i := 1 to n do   
readln(a[i]); 
for i := 1 to n do   
write(a[i], '   '); 
min := a[1]; 
max := a[1]; 
imin := 1;
imax := 1;  
for j := 1 to n do 
begin   
if(a[j] > max) then  
begin    
max := a[j];     
imax := j;   
end;   
if(a[j] < min) then   
begin     
min := a[j];     
imin := j;   
end; 
end; 
writeln(); 
writeln('индекс минимального элемента ', imin, ' индекс максимального элемента ', imax); 
m := abs(imin - imax); 
Writeln(); 
Writeln('Кол-во элементов между макс. и мин. элементами ', m - 1);
end.

(14.3k баллов)
0

можно без вычисления индекса?

0

в массиве только так

0

хорошо,спасибо