Напишите программу определения давления d ** грунт опоры массой m, форма основания...

0 голосов
217 просмотров

Напишите программу определения давления d на грунт опоры массой m, форма основания которой - круг радиусом r с вырезанным из его центральной части квадратом со стороной a, по указанной формуле
d=\frac{9,8}{3,14(r^{2}-a^{2}) }
составлять через turbo pascal


Информатика (15 баллов) | 217 просмотров
0

Указанная формула содержит минимум 2 ошибки. 1)Числитель надо домножить на массу. 2)Знаменатель должен выглядеть так: (3,14r - a) (r и a - обе переменные в квадрате).

Дан 1 ответ
0 голосов
Правильный ответ

Uses Crt;
Const
   g = 9.8;
Var
   r,a,d:real;
Begin
ClrScr;
Write('r = ');ReadLn(r);
Write('a = ');ReadLn(a);
d:=g/(Pi*(r*r-a*a));
WriteLn('d = ',d);
ReadLn
End.

(34.0k баллов)
0

Поскольку формула ошибочная, то и программа содержит те же ошибки - о чём, собственно, и был написан первый комментарий. То есть программа правильная, но давление она будет считать неверно. Потому как прежде информатики следует выучить физику и геометрию.