Написать программу которая сумму всех цифр пятизначного числа х который вводится с...

0 голосов
49 просмотров

Написать программу которая сумму всех цифр пятизначного числа х который вводится с клавиатуры и определит заканчивается ли эта сумма на три и четная эта сумма или нет
Информатика 8 класс


Информатика (66 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
var a: longint;
procedure sumdig(var x: longint);
var s:longint;
begin
s:=0;
while ( x<>0 ) do
begin
s := s + (x mod 10);
x := x div 10;
end;
if s mod 10=3 then writeln('оканчивается на 3')
else writeln('не оканчивается на 3');
if s mod 2=0 then writeln('четная') else
writeln('нечетная');
end;
begin
writeln('введите целое число');
readln(a);
sumdig(a);
end.

(150k баллов)