Написать программу, которая вводит массив из N вещественных чисел, а затем заменяет в нём...

0 голосов
67 просмотров

Написать программу, которая вводит массив из N вещественных чисел, а затем заменяет в нём все элементы, превышающие данное число Z, этим числом. Вывести на экран полученный массив и количество замен. Протестировать программу на следующих исходных данных:
а) Z=10 Массив: 1,2 2,6 3 -4,5 11 10,2 3,2 87 -15
б) Z=-2 Массив: 0 -3,1 11 -7,9 -2,1 -1,9 4


Информатика (21 баллов) | 67 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.Net 3.2
begin
var a:=readARRreal('Вводите: ', readinteger('n ='));
var z:=readreal('z ='); var count:=0;
for var i:=0 to length(a)-1 do if a[i]>z then begin
a[i]:=z;
count+=1;
end;
writeln ('Кол-во замен: ', count);
a.Print;
end.

(3.8k баллов)