Составить программу, которая выводит ** экран в обратном порядке нечетные числа от 29 до...

0 голосов
139 просмотров

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.
Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.



Информатика (17 баллов) | 139 просмотров
Дано ответов: 2
0 голосов

1) program zad1;
var a: integer;
begin
a:=29;
while a>0 do
begin
if (a mod 2=1) then
writeln(a);
a:=a-1;
end;
end.

(188 баллов)
0 голосов

Var i:integer;
begin     
i := 30;     
while (i >= 1) do     
begin         
if (i mod 2 = 1) then           
writeln(i);       
 i := i - 1;     
end;
end.
----------------
2)
var i, a: integer;
begin   
for i:=0 to 30 do       
if (i mod 2 = 1) then         
a := a + i;   
writeln(a);
end.
------------
Удачи:)

(16.9k баллов)