Вопрос по информатике. Написать программу ** языке FreePascal. Дан массив определённой...

0 голосов
39 просмотров

Вопрос по информатике. Написать программу на языке FreePascal. Дан массив определённой длины, в котором могут быть как положительные, так и отрицательные числа. Проинициализировать массив и найти кол-во элементов массива до первого отрицательного и сумму элементов после него


Информатика (107 баллов) | 39 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Uses Crt;
Const
   N = 13;
Var
   A:array[1..N] of integer;
   i,k:integer;
   S:real;
Begin
Randomize;
ClrScr;
For i:= 1 to N do
    Begin
    A[i]:=random(21)-10;
    Write(A[i],' ')
    End;
WriteLn;
i:=1;
k:=0;
While (A[i]>=0)and(i   Begin
   k:=k+1;
   i:=i+1
   End;
if A[i]>=0 then k:=k+1;
WriteLn('k = ',k);
S:=0;
For i:= i+1 to N do
    S:=S+A[i];
WriteLn('S = ',S:0:3);
ReadLn
End.

(34.0k баллов)
0

Спасибо большое!))