Напишите программу формирования и вывода массива размером 6x3, каждые три...

0 голосов
37 просмотров

Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:

1-й — равен сумме текущих индексов, увеличенной в 10 раз;

2-й — равен целой части от деления случайного числа на сумму текущих индексов;

3-й — равен разности двух предыдущих элементов.


Информатика (279 баллов) | 37 просмотров
0

Паскаль

Дан 1 ответ
0 голосов
Правильный ответ

Const
   N = 6;
Var
   A:array[1..N,1..3] of integer;
   i:integer;
Begin
Randomize;
For i:= 1 to N do
    Begin
    A[i,1]:=i*10;
    A[i,2]:=random(i*13) div (i+2);
    A[i,3]:=A[i,2]-A[i,1];
    WriteLn(A[i,1],' ',A[i,2],' ',A[i,3])
    End;
End.

(34.0k баллов)