PascalВыведите все числа ** отрезке от a до b, являющиеся полными...

0 голосов
132 просмотров
Pascal
Выведите все числа на отрезке от a до b, являющиеся полными квадратами.
Примеры:
Входные данные
1
5
Выходные данные
1 4

Информатика (17 баллов) | 132 просмотров
Дан 1 ответ
0 голосов

Var a,b,i:integer;
      x:real;
Begin
Readln(a);
Readln(b);
If a<0 Then a:=1;<br>For i:=a to b do
 Begin
  x:=sqrt(i);
  If frac(x)=0 Then Write(i,' ');
 End;
End.

(122 баллов)
0

Если вводишь отрицательное число как a, то вылетает ошибка. Программа работает только на множестве действительных.

0

Исправил:) Извиняюсь!

0

Нечего, бывает)

0

что такое frac(x)?

0

Дробная часть, допустим у вас число 1.5, тогда frac(1.5)=0.5