Напишите программу, которая сортирует массив целых чисел в порядке возрастания...

0 голосов
172 просмотров

Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input.txt , отсортированный массив нужно вывести в файл output.txt .

Входные данные
Первая строка входного файла input.txt содержит размер массива. Во второй строке записаны все элементы массива, разделённые пробелами.

Выходные данные
Программа должна вывести в файл output.txt все элементы отсортированного массива в одной строке, разделив их пробелами.

Примеры
входные данные
5
5 1 4 2 3
выходные данные
1 2 3 4 5


Информатика | 172 просмотров
0

Паскаль? C++?

Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
type z = array of integer;
var a: z;
i,n,x,j,buf: integer;
f: text;
begin
randomize;
assign(f,'input.txt');
reset(f);
n:=0;
readln(f,x);
setlength(a,x);
while not eof(f) do
begin
read(f,a[n]);
n:=n+1;
end;
close(f);
for i:=0 to n-2 do
for j:=i+1 to n-1 do
if a[i]>a[j] then begin
buf:=a[i];
a[i]:=a[j];
a[j]:=buf;
end;
assign(f,'output.txt');
rewrite(f);
for i:=0 to x-1 do write(f,a[i],' ');
close(f);
end.

(150k баллов)