1)Написать программу нахождения суммы квадратов чисел от 5 до 25 2) Дан массив А,...

0 голосов
60 просмотров

1)Написать программу нахождения суммы квадратов чисел от 5 до 25
2) Дан массив А, состоящий из 15 целых чисел. Заполнен с клавиатуры. Найти произведение элементов массива, больших 5.
Паскаль


Информатика (36 баллов) | 60 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET версия 3.2, сборка 1389
//Если программа не запускается, то обновите версию
begin
    Writeln('суммa квадратов чисел от 5 до 25 =', Range(5, 25).Select(x -> x * x).Sum);
    writeln;
    
    var a := ArrGen(15, i -> ReadInteger('a[' + i.toString() + ']='), 1);
    writeln('произведение элементов массива, больших 5 =', a.Where(x -> x > 5).Aggregate(1, (x, y)-> x * y));
end.

(55.0k баллов)