Нужно написать программу срочно!!!!!

0 голосов
39 просмотров

Нужно написать программу срочно!!!!!


image

Информатика (12 баллов) | 39 просмотров
0

На чем: C++, Python, Pascal`и?

0

Pascal

0

Ок

Дан 1 ответ
0 голосов

//PascalABC.Net 3.2
function f(x: real):real;
begin
if x=trunc(x) then
 if trunc(x).iseven then result:=x*x*x*x*x else result:=1/(x*x-10)
    else result:=x;
end;

begin
write ('y = ', f(readreal('x =')));
end.

(3.8k баллов)
0

Можно написать "проще"

0

Только незачем!