Напишите программу ♥♥♥ нахождения суммы элементов массива А[1..15], кратных 7 или 17....

0 голосов
46 просмотров

Напишите программу ♥♥♥

нахождения суммы
элементов массива
А[1..15], кратных 7 или
17. Массив заполняется
произвольными
числами в диапазоне да
100.


Информатика (41 баллов) | 46 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
var a: array[1..15] of integer;
sum,i: integer;
begin
randomize;
write('исходный массив: ');
sum:=0;
for i:=1 to 15 do
begin
a[i]:=random(101);
write(a[i],' ');
if (a[i] mod 7=0) or (a[i] mod 17=0) then
sum:=sum+a[i];
end;
writeln;
write('сумма: ',sum);
end.

(149k баллов)
0

спасибо♥