Напишите программу(паскаль) нахождения суммы элементов массива А[1..15], кратных 5 и...

0 голосов
56 просмотров

Напишите программу(паскаль) нахождения суммы элементов массива А[1..15], кратных 5 и меньших 50. Массив заполняется произвольными числами в диапазоне да 100


Информатика (94 баллов) | 56 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
var a: array[1..15] of integer;
sum,i: integer;
begin
randomize;
write('исходный массив: ');
sum:=0;
for i:=1 to 15 do
begin
a[i]:=random(101);
write(a[i],' ');
if (a[i]<50) and (a[i] mod 5=0) then<br>sum:=sum+a[i];
end;
writeln;
write('сумма: ',sum);
end.

(150k баллов)