Напишите программу заполнения массива А[1:50] числом 1

0 голосов
66 просмотров

Напишите программу заполнения массива А[1:50] числом 1


Информатика (94 баллов) | 66 просмотров
0

Так ведь есть уже программа? В чём с ней проблема?

0

То, что вы писали? Там было по нахождению суммы..

0

Так там массив заполняется единицами. A[i]:=1; - в этой строчке

0

Аа)) ладно) спасибо

Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1401 от 14.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrFill(50,1); a.Println
end.

Замечание: полученный массив имеет 50 элементов, но индексы [0..49]

2. "Школьный вариант"
var
  a:array[1..50] of integer;
  i:integer;

begin
  for i:=1 to 50 do begin
    a[i]:=1;
    Write(a[i]:2)
    end;
  Writeln
end.
(150k баллов)