Написать программу решения уравнения ах3 + bх = 0 для произвольных а, b. ** СИ

0 голосов
161 просмотров

Написать программу решения уравнения ах3 + bх = 0 для произвольных а, b.
На СИ


Информатика (26 баллов) | 161 просмотров
0

Это икс в третьей степени?

0

Да

Дан 1 ответ
0 голосов
Правильный ответ

Рассмотрим уравнение вида ax³ + bx = 0
Его также можно представить в виде x(ax² + b) = 0 
Это же равносильно системе
[ x = 0
[ x = ±√( -b / a )
Понятно, что решением этого уравнения, независимо от коэффициентов, будет всегда являться 0. Также уравнение будет иметь и другие корни, при a ≠ 0 и -b / a > 0, это x = ±√( -b / a )

Решение на С
#include
#include
int main() {
    // Ввод данных
    float a, b;
    printf("a = ");
    scanf("%f", &a);
    printf("b = ");
    scanf("%f", &b);
    // Первый корень уравнения
    printf("x1 = 0\n");
    // Второй и третий корни уравнения
    if (a != 0 && -b / a > 0) {
        printf("x2 = %.3f \n", -sqrt(-b / a));
        printf("x3 = %.3f \n", sqrt(-b / a));
    }
    return 0;
}

(13.3k баллов)