Написать программу, которая вводит натуральное число n и считает сумму чисел от 1 до n

0 голосов
48 просмотров

Написать программу, которая вводит натуральное число n и считает сумму чисел от 1 до n


Информатика (20 баллов) | 48 просмотров
0

Паскаль?

0

Да!

Дано ответов: 2
0 голосов
Правильный ответ

Var
n:integer;
S:real;
Begin
S:=0;
Write('n = ');
ReadLn(n);
For n:= 1 to n do
    S:=S+n;
Write('S = ',S)
End.

(34.0k баллов)
0 голосов

Program sum_n;
var
n, i, s: integer;
begin
write('n = ');
readln(n);
s := 0;
for i := 1 to n do
s := s + i;
writeln('s = ', s);
end.

(7.2k баллов)